Outboard Motor Repair Outboard Motor Repair  

Outboard Motors

Power Heads

Lower Units

Props

Repair Manuals

Controls, Steering

Trim/Tilt

Power Tilt/Trim

Parts

Outboard Motor Repair


Chrysler
Evinrude
Force
Honda
Johnson
Mariner
Mercury
Minn Kota
Nissan
OMC
Suzuki
Yamaha
2 Cycle Outboard Motors
2 Stroke Outboards
4 Cycle Outboards
4 Stroke Outboards
Aftermarket Outboard Parts
Boat Wont Plane
Bolts
Brackets
Carburetors
Cavitation
Choke
Coils
Compression
Condensors
Controls
Cooling
Cowling
Crankshafts
Cylinders
Diagrams
EFI
Electrical
Engine Cleaner
Engine Smoke
Exhaust
FICHT
Fins
Flywheel
Fouling
Fuel Pumps
Fuel Systems
Fuel Tanks
Gaskets
Gauges
Gear Cases
Generators
I/O
Idle
Ignition
Impellers
Inverters
Kill Switch
Leaks
Lower Units
Lubrication
Manuals
Oil
Oil Injection
Oil Mixture
Old Outboards
Outboard Engine Blocks
Outboard Inboard
Outboard Maintenance
Outboard Motor Prices
Outboard Propellers
Paint
Parts
Pistons
Power Loss
Power Packs
Powerheads
Primer Bulb
RPM
Repair Tools
Reverse
Running Lean
Running Rich
Runs Hot
Sea Drives
Sealants
Shafts
Shifter
Skegs
Spark Plugs
Specs
Spring Maintenance
Starter Motors
Starting Problems
Stators
Steering
Synthetic Oil
Tachometers
Tillers
Tilt Trim
Timing
Trim Tabs
Twin Outboards
V6
Voltmeter
Water Pumps
Winterization
Wiring
Year

MERCURY SPORT JET 90 HP TOO SLOW

RICHRICH26 Please someone help me. I have a bayliner jet jazz 90hp sportjet which will not go above 5 mph. Things I have done so far: Rebuilt carbs, compression 120-120-122, .032" clearance between impeller and housing, impeller looks great, new ride plate gasket, engine rpm's within spec. As you can see I have invested alot of money so far and any ideas no matter how small will be greatly appreciated. Thank you 2002-04-17
Trent Crawford Have you checked the rev limiter? 2002-04-17
RICHRICH26 No I have not checked the rev limiter the rpm's seem fine 4000 or better engine sounds and runs great seems like problem is in the jet prop 2002-04-17
RICHRICH26 sorry something else I wanted to say is I am open for ANY suggestions 2002-04-17
ODDD1 rich, if you actually have the impeller hooked to the motor [no gear failure] the only thing that will cause you to make rpm's and not move is air in the inlet water stream of the pump....exhaust gas or air ...it is getting in there and screwing things up.... 2002-04-17
RICHRICH26 about the air thing... it is my last resort, but with the ride plate gasket making a good seal i cant figure any other way of air getting in there. is .032" clearance satisfactory for impeller to housing??? is there any time of slip device on the impeller? i can turn the impeller and feel the compression strokes of the engine with no slop or play. 2002-04-17
Terry H Rich...There is a spline on the shaft that can shear if impeller gets jammed. Check the spline and the lock washer on the nut...Make sure these are ok and make sure the nut is properly torqued. I think the torque specs call 18ft.lbs...Impeller clearance should be .020-.030, .032 should be fine.
just a Thought
2002-04-18
muskiedaze rich, one other possibility: is the reverse gate locking properly in the forward position? if it kicks back ya won't go. but my best guess is the key on the drive shaft is broken and the pieces can jam up and let you turn the motor.
john
2002-04-18
RICHRICH26 About the spline on the impeller, I thought about that but the shaft is actually a threaded rod in which the impeller screws directly on the shaft so there is no option for slippage on that part the gate thing sounds like a possibility but the gate is staying up and out of the way of the nozzle. I am back to thinking possibly the drive plate gasket how well of a seal is needed??? Is there any other way for air/exhaust to enter the intake and cause the pump to cavitate??? 2002-04-18
RICHRICH26 The reverse gate needs to be up and out of the way of the nozzle to work doesent it??? It seems like the boat just doesnt want to plane off. 2002-04-18
RICHRICH26 Thursday 4/18/02 put a little silicone rtv gasket maker on ride plate gasket seemed to do better for about 3 minutes in water then went back to her old self... Could the ride plate gasket be giving me all of this grief??? The gasket looks fine any suggestions anyone??? 2002-04-18
ODDD1 Yes rich, ride plate gasket/ ride plate itself will cause this...have seen many ride plates 'sneezed' off the bottom of the pump by people starting them up out of water...recheck all fasteners on the plate, caulk the gasket to eliminate any leaks between plate an hull, it has to be a PERFECT water tight seal.... 2002-04-18
RICHRICH26 Ok got new ride plate gasket today $57.00 not to bad but in stock got it on the boat put boat in water boat is better but not the best she will do 20 at best it just doesnt seem right for a mercury 90 with a 14' boat, could I be wrong??? If someone has their opinion on this boat I would greatly appreciate it. And thank you guys for all of the input so far it has helped alot 2002-04-19
Ledif7 I have a regal rush 1994 , same mercury 90 hp . I just got it. I tested it in the bay and seems to go too slow. mileage metter broken. I will try the same thing put a gasket to see if it goes faster. When I hit the trottle it makes a noise like the impeller runs out of water. I will keep you posted on the results. 2002-04-19
ODDD1 Rich...last jazz I fixed ride plate on an 'Adjusted' the trim......42 mph....with a 90 SJ...you got a ways to go.... 2002-04-19
RICHRICH26 42 MPH would be like hitting to lottery to me at this time. You raised a good question how do I adjust the trim on my jazz does the gate have to be totally up and out of the way of the nozzle or is there some tricks I dont know about??? 2002-04-20
ODDD1 Rich, the gate doesnt hang down in the nozzle...make sure it clears....trim is accomplished with the rear two ride plate anchor bolts....they had spacers on them, didn't they? Add additional washers to push the back of the ride plate down....will help boat run flatter, especially with a light load... 2002-04-20
Ledif7 I have a 94 reagal rush a 90 hp. The rudder has a opening at the bottom end . About 2 inches wide and 2 inches deep. Is that the way it is suposed to be? At the bottom it has a screw with something round atached to it but it seems it has no used for it. I was wondering it something was missing, thankyou. 2002-04-20
RICHRICH26 ODDD1, I am scared that if I space the ride plate rear I will lose a good seal with the ride plate gasket or am I misunderstanding you??? you are talking about the 2 screws closest to the nozzle that bolt in to the stator correct? 2002-04-20
RICHRICH26 Led, the nozzle is suppose to have a notch in it to direct some of the water down. The round thing you are talking about is your zinc. If it is badly pitted I would replace it before you start getting galvanic corrosion on your engine parts 2002-04-21
ODDD1 Yes rich..those are the bolts I am talkin about...if you look at your ride plate, you will see a notch in the side flanges where the plate is supposed to bend to change the trim....be gentle...add a washer at a time to check effect... 2002-04-21
RICHRICH26 ODDD1, You are exactly right, thank you very much for your help. Will a 1/8" washer make very much difference??? 2002-04-22
Ledif7 did the boat run faster after the trim adjusment? 2002-04-25
RICHRICH26 No it did not. I am at a loss and at wits end. I am still doing about 5 mph. Let me go over what I have done so far maybe there is someone with the "magic fix" Carbs rebuilt, new ride plate gasket, new plugs, new gas, .032" clearance between impeller and housing, impeller good no nicks, 4500 rpm at w.o.t., add spacers to trim 1/4 total, 1 person in boat, and every other minor check. If there is someone with even a slight idea I will be more than happy to hear it. 2002-04-28
clanton Led. Are you close to Citrus county. 2002-04-28
pmpiper@hotmail.com I haven't worked on a jet drive but it doesn't need a leak in something to cavitate. Are you sure the water inlet is clear? 2002-04-29
RICHRICH26 that was the first thing I checked 2002-04-30
Thena I recently had a sportjet 90hp engine rebuilt for a 152 donzi medallion.

The Engines seems to work fine but the boat seems to have a hard time to plane and when it does it runs at 20-25mph.

I've checked the impeler and it is in perfect condition. There is nothing blocking the way. What could be wrong??

I've run out of ideas.
2002-05-21
russthemuss Geee ,Check your running the right spec impellor for the engine.Has it ever run well? 4500rpm seems a bit low but i dont know your specs.Is the hull full of water!! Check the thread on the shaft at the coupling.Check the coupling,check the impellor drive.Pull it all apart! 2002-05-23

If you would like to post your own question for the experts just click on
the Boating Forums tab at the top of the page or click here!

Disclaimer: iboats.com provides this content for the education and benefit of all boating enthusiasts.
We cannot, however, take responsibility for individual postings, nor can we verify the accuracy of any posting.
Please use any information provided from individuals with great care and read any applicable manuals or safety instructions.
Also, if you determine that a posting is inaccurate or offensive in any manner, please use the Contact Us email form found below.

If you would like to post your own question for the experts just click on the Boating Forums tab at the top of the page!


Outboard Motors

Power Heads

Lower Units

Props

Repair Manuals

Controls, Steering

Trim/Tilt

Power Tilt/Trim

Parts

Outboard Repairs | Boats | Outboard Motors | Boat Dealers
Boat Covers | Boat Propellers | Boat Repair | Marine Engines | Outboard Forum Directory
Terms of Use | Privacy Practices | Legal Notices

1-800-869-1686 (Toll Free)
001-801-571-0071 (International Calls)
Copyright © 1999-2009 iboats, inc. All rights reserved.